Closed Thread
Results 1 to 6 of 6

Thread: Dash display / screen not working

  1. #1
    VXR newbie
    Join Date
    21st July 2011
    Posts
    3

    Default On board display / screen not working

    Hi Guys,

    Hoping someone will be able to help here.

    I have a 2008 Opel Astra OPC/VXR with CD30 MP3, A few weeks ago my Dash display / Screen suddenly stopped working.

    Here are the following symptoms:-
    • Dash display / Screen not working.
    • Steering wheel controls not working.
    • Backlighting on radio controls not working.
    • Radio/CD works but does not turn on or off automatically. I.e. when ignition is turned on & off.
    • I now have the following error code 007072

    That same day I disconnected the battery overnight & the following morning turned on the ignition with everything working 100%. I then reversed out the driveway, drove 100m up the road and the screen went dead again along with all the problems listed above & has not worked since whether I disconnect the battery or not.

    I have taken the car to the local GM dealer at Hatfield & they tell me I must buy a new unit. This is of course a very pricey exercise & I’m not sure that this is where the problem lies.

    Any ideas?
    Last edited by OPC HAAS; 21st July 2011 at 04:03 PM.

  2. #2
    VXR Nothing comes close vr55vxr's Avatar
    Join Date
    6th February 2008
    Posts
    12,508

    Default

    Not sure on the fix, but if you are saying that your dash dials are not working do you realise it is illegal to drive without any working speedo.

  3. #3
    VXR Torque of the Devil scorer's Avatar
    Join Date
    23rd May 2009
    Posts
    5,097

    Default

    Thats a shame would be a great excuse lol

  4. #4
    VXR newbie
    Join Date
    21st July 2011
    Posts
    3

    Default

    Quote Originally Posted by vr55vxr View Post
    Not sure on the fix, but if you are saying that your dash dials are not working do you realise it is illegal to drive without any working speedo.
    When i say Dash display, i really mean my On board display...no problems with the speedo.

  5. #5
    The Red Baron... Deathace's Avatar
    Join Date
    25th May 2011
    Posts
    6,123

    Default

    it sounds like your stereo is on the way out and as a result is messing up the display for normal operation as well as the radio (shorting it out) I would try and remove the stereo and disconnect the cables give it a good blow through with air and check the connections of the display as that may be loose or intermittent problem maybe due to vibration or something similar.

    Dry solder joints is one of the main killers for stereos as the vibration from daily use makes the solder joint brittle and then it parts from the board and makes the connection now and then when a bump touches them together. They are fixable but most places will charge a small fortune to diagnose and fault find by which time a new unit will work out cheaper or why not go for a change and pick any stereo you want thats compatible with the display.

    try the above first see how you get on also check the fuse on the back of the stereo it might be worth changing it anyway.

    Russ

  6. #6
    VXR newbie
    Join Date
    21st July 2011
    Posts
    3

    Default

    Thanks for the reply Russ, as i said the car has been back to the local Opel/Vauxhall dealer who have told me all the wiring has been checked without faults but what i can believe from that im not sure. They tell me they have stripped out the centre consol and checked everything but unless i spend the whole day with them and see with my own two eyes, it is difficult to trust the dealers these days. they charge a fortune for labour with the least amount of effort. Do you know what units would be compatable if i was to go this route?

    Chris.

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts