Closed Thread
Results 1 to 7 of 7
  1. #1
    VXRed blooded woochar's Avatar
    Join Date
    26th June 2012
    Posts
    297

    Default HELP Cobra doesn't fit!!

    Hey guys, I got my cobra catback exhaust today but when I fitted it, first of all I had a nightmare with the original pipe and ended up having to cut it off. when I put the cobra on, the centre pipe seemed too big for the main cat pipe. It seemed as tho the flange is too big for the ball end of the cat pipe and there was too much movement. I started it up and the exhaust was blowing. Am I missing something? My car is now off road cos the original pipe is fudged! Please help someone! I need my car! I have emailed just performance but wondered if anyone here has had any similar problem. Cheers

  2. #2
    Are you VXR enough?
    Join Date
    12th August 2008
    Posts
    892

    Default

    Did you buy the 2.5" or 3" catback system?

  3. #3
    VXRed blooded woochar's Avatar
    Join Date
    26th June 2012
    Posts
    297

    Default

    Quote Originally Posted by Mixman View Post
    Did you buy the 2.5" or 3" catback system?
    It's the 2.5

  4. #4
    VXR enough Prohibit's Avatar
    Join Date
    4th February 2012
    Posts
    1,053

    Default

    Exhaust removals and fittings is defiantly a job for the garage. I was perfectly capable of fitting my whiteline rear anti roll bar and soldering extension wires for my MAF sensor, etc, I thought to myself "how hard can it be to fit a new exhaust".

    I was so wrong. Spent about 2 hours under the car on jacks trying to get the old exhaust off and couldn't even do that because it was so solid and difficult. All the hangers were a huge pain and the nuts and bolts on the cat had rusted solid. In the end I drove it down to the garage with the exhaust hanging by cable ties.

    Also, did you use any exhaust sealent/putty in the joints of the exhaust? If you haven't then that's what is causing it to blow.

  5. #5
    VXRed blooded woochar's Avatar
    Join Date
    26th June 2012
    Posts
    297

    Default

    Well It wasn't actually me it was my mate who is a part time mechanic trying to fit the new one. I'm pretty sure there's something missing from the box

  6. #6
    Regional Assistant - Essex Hey Mr Chicken badboyburt's Avatar
    Join Date
    13th July 2009
    Posts
    47,883

    Default

    PM Royboyvxr he also had issues with a new Cobra sounds like your having the same.

    V8, not for everyone but 10/10 for your effort.

  7. #7
    VXRed
    Join Date
    2nd October 2012
    Posts
    164

    Default

    Hi mate, Sorry to hear you are having problems, If you haven't sorted it out and you are close to Ashford we will be pleased to help you out and fit it for you.

Closed Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts