Closed Thread
Results 1 to 8 of 8

Thread: Turbo lag!?????

  1. #1
    VXRed
    Join Date
    14th August 2013
    Posts
    22

    Red face Turbo lag!?????

    Hello there I have a 2008 astra vxr! It is t as sharp on the throttle as it should be! My mate has exactly the same car running the same stuff, same map and same brake! He is a lot sharper! It's got a pace intercooler, a forged recirculation valve a blue flame exhaust and just had cdti conversion airbox kit put on it! Any ideas please ??? Thanks

  2. #2
    VXRed
    Join Date
    28th July 2013
    Posts
    175

    Default

    Turbo boost pipes could be the poblem mate have you checked them? I had same problem with my Vxr on boost and asked on here. Poster called dryburgh had a look at the car and plugged in his boost gauge to find that a boost pipe had came off, do you have a boost gauge you could stick on? Sure there's a few more guys on here that could help you out if thats not your problem.good luck

  3. #3
    Do you love him or hate him? wezzel98765's Avatar
    Join Date
    7th February 2010
    Posts
    3,515

    Default

    Do you have a boost guage at all?

    It does sound as though you've got some sort of boost leak to be honest, obviously filling up a nice big intercooler with air can take time, but if your mate has the same setup, then it sounds as though there is a leak somewhere

  4. #4
    VXR enough jc1992's Avatar
    Join Date
    11th February 2013
    Posts
    1,185

    Default

    if you have standard vac lines they are prone to having little cracks which will loose a little bit of boost, is the map a custom or generic map?

  5. #5
    VXR Nothing comes close R15VXR's Avatar
    Join Date
    13th May 2008
    Posts
    21,627

    Default

    Quote Originally Posted by Kierantate View Post
    Hello there I have a 2008 astra vxr! It is t as sharp on the throttle as it should be! My mate has exactly the same car running the same stuff, same map and same brake! He is a lot sharper! It's got a pace intercooler, a forged recirculation valve a blue flame exhaust and just had cdti conversion airbox kit put on it! Any ideas please ??? Thanks
    So whats your setup in comparison ???

  6. #6
    VXRed
    Join Date
    14th August 2013
    Posts
    22

    Default

    thank you guys! it was a vac pipe that had come off! had a new one put on now and works fine+ yess a bigger intercooler can cause lag I believe that's what ive been told elsewhere! cheers.

  7. #7
    VXR enough matthewt23's Avatar
    Join Date
    6th March 2012
    Posts
    4,317

    Default

    Quote Originally Posted by R15VXR View Post
    So whats your setup in comparison ???
    Quote Originally Posted by Kierantate View Post
    My mate has exactly the same car running the same stuff, same map and same brake! He is a lot sharper!

    It's got a pace intercooler, a forged recirculation valve a blue flame exhaust and just had cdti conversion airbox kit put on it!
    ...

  8. #8
    Banned
    Join Date
    23rd July 2010
    Posts
    15,847

    Default

    Quote Originally Posted by matthewt23 View Post
    ...
    Trolling hashtagging

    Sent from my C6603 using Tapatalk 2

Closed Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts