Closed Thread
Results 1 to 3 of 3
  1. #1
    VXRed
    Join Date
    23rd March 2014
    Posts
    15

    Default Turbo housing offset?

    I bought a second hand turbo which has had a new core fitted and balanced, i fitted the turbo but am only getting 9psi on the gauge. ive got a cone filter, it sounds like its sucking alot harsher, like its really spooling up than my old turbo which was fine, i just needed a new manifold as mine was cracked. checked for boost leaks but can find anything.

    the only thing i have noticed is that the housing seems to be set back a bit compared to my original turbo. Where the actuator plate is meant to sit flush against the housing, it doesnt!

    Circled the step where the housing is set back.



    Circled no step on the original turbo with the actuator fixing plate sitting flush.


    I have also noticed it isnt a VXR actuator, would this make much of a difference, ive adjusted the actuator up and down and didnt notice a difference.

    im not 100% sure on how a turbo is put together so would the housing being set back matter?

    Thanks

  2. #2
    VXRed
    Join Date
    23rd March 2014
    Posts
    15

    Default

    Anyone?? Would this cause me to lose power?

  3. #3
    VXR Torque of the Devil Dan_vxR's Avatar
    Join Date
    1st October 2009
    Posts
    8,389

    Default

    need more and less close up pics to see

    Obsessed is a word that the lazy use to describe the dedicated!

Closed Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts