+ Reply to Thread
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
  1. #11
    VXRed Foli's Avatar
    Join Date
    20th April 2017
    Posts
    76

    Default

    I haven't yet, I'm going to take it for another run and double confirm the issue then I'll put the crossover on with the cone and see if it's the same.


    Sent from my iPhone using Tapatalk Pro

    Crossover delete, ITG cone filter
    3" cat back by Fast Road Conversions

  2. #12
    VXR Nothing comes close VXRRy's Avatar
    Join Date
    15th May 2013
    Posts
    16,160

    Default Losing boost with induction kit

    If not bring it to AMD Essex on Sunday and a few of the boys will have a look at see if there's anything amiss


    Sent from my iPhone using Tapatalk

  3. #13
    VXRed VinPetrol's Avatar
    Join Date
    13th June 2016
    Posts
    205

    Default

    Might sound like a stupid thing to say but double check the jubilees are tight and that there's a good seal onto the top of the turbo. If it's dragging in unmetered air after the MAF, especially when the turbo is really sucking, it will throw your fuelling out the window.

    Might be wrong but worth a try. I've seen it once before where a jubilee seemed tight but was cross threaded and the vac seal wasn't good.

  4. #14
    VXRed Foli's Avatar
    Join Date
    20th April 2017
    Posts
    76

    Default Losing boost with induction kit

    So I've taken it out for a good thrashing and it's no longer having an issue at all. The only thing I'd say is if I press the throttle to the floor it doesn't seem to respond as well as a lighter press but I guess that sort of thing can be down to the map?

    I noticed this morning I've got a stem seal issue so I'll see if I can take it somewhere who can have a look at it and see if there's any issue with the mapping as well.

    Thank you all for your input, hopefully it doesn't start up again.

    Sent from my iPhone using Tapatalk Pro

    Crossover delete, ITG cone filter
    3" cat back by Fast Road Conversions

+ Reply to Thread
Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts