+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    VXR newbie
    Join Date
    5th January 2018
    Posts
    6

    Default Boost surgeing issue

    https://youtu.be/rjgFHQKQgIw

    Any ideas on what could be causing it ?

  2. #2
    VXRed blooded Damo24LFC's Avatar
    Join Date
    18th September 2017
    Posts
    479

    Default

    It’s hard too see but how’s it driving in general and what’s exactly happening
    07 Arden blue VXR(H). 3” scorpion turbo back, pipercross cone filter, front mounted intercooler. Running stage 2 map dyno tested at 290bhp 340 lb torque.
    Black rear diffuser, black boot trim, black tinted windows. Piano black console and steering wheel trims. Carbon fibre dash trims.

  3. #3
    Are you VXR enough? andy-'s Avatar
    Join Date
    12th May 2010
    Posts
    871

    Default

    Dunno but I think you need brake fluid (light on dash is the brake warning one)
    Vectra VXR 280. Milltek cat back. Courts upgraded radiator. Courts intercooler. K&N filter. Eibach springs. TD Pro race 1.2s

  4. #4
    VXR newbie
    Join Date
    5th January 2018
    Posts
    6

    Default

    Quote Originally Posted by Damo24LFC View Post
    It’s hard too see but how’s it driving in general and what’s exactly happening
    semms alright tbh part from setting off n sometimes when pressing back down on accelerator it will serge boost then die down again , but while driving like going to over take boost will start to come on then it will just ccome on and off like its trying to but just carnt quite do it like if you listen to the engine as you watch the boost gauage

  5. #5
    VXR newbie
    Join Date
    5th January 2018
    Posts
    6

    Default

    Quote Originally Posted by andy- View Post
    Dunno but I think you need brake fluid (light on dash is the brake warning one)
    i caught the handbrake a bit thats why it came on

  6. #6
    VXRed
    Join Date
    14th September 2016
    Posts
    58

    Default

    Mine is doing the exact same mate and been told its the boost control solenoid situated on the turbo

  7. #7
    VXR newbie
    Join Date
    5th January 2018
    Posts
    6

    Default

    Quote Originally Posted by Rabbit_vxr View Post
    Mine is doing the exact same mate and been told its the boost control solenoid situated on the turbo
    already changed it mate but still the same

  8. #8
    VXR newbie
    Join Date
    5th January 2018
    Posts
    6

    Default

    no stored fault codes eather

  9. #9
    VXR enough chodiddly's Avatar
    Join Date
    12th December 2015
    Posts
    1,607

    Default

    cud it be a slight tear in the recirc valve? i know when mine tore i was gettin turkey noise but mine was more than a slight tear lol

    Vac lines all gravy?

  10. #10
    VXRed blooded
    Join Date
    11th July 2017
    Posts
    319

    Default

    do your self a favour and delete that video asap ...2 offences plain as day...never ever show the speedo for a start
    But anyway...yeah looks like either the boost valve is opening early due to the map sensor thinking boost is higher than really is so may need a new Map sensor Or
    Wastegate spring could be getting tired and opening on its own under boost.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts