+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    VXRed
    Join Date
    26th June 2016
    Posts
    90

    Default Heater controls siezed

    Hi all.

    My corsa has been sat around for some time, gathering rust on the drive way.

    I fired it up and tried to turn the heating controls on. The temperature control works fine, although the control that distributes the air doesn’t seem to work. It just seems to keep turning and only comes out on one setting.

    Is this normal? I’ve looked and some people have said take the radio out?

    Has anyone else experienced this?

    Cheers

  2. #2
    VXRacing ahead Brucerutherford's Avatar
    Join Date
    15th January 2014
    Posts
    648

    Default

    Quote Originally Posted by VXR Andrew View Post
    Hi all.

    My corsa has been sat around for some time, gathering rust on the drive way.

    I fired it up and tried to turn the heating controls on. The temperature control works fine, although the control that distributes the air doesn’t seem to work. It just seems to keep turning and only comes out on one setting.

    Is this normal? I’ve looked and some people have said take the radio out?

    Has anyone else experienced this?

    Cheers
    Does it only work on the highest setting or something?

    Sounds like the Heater Resistor if I'm not mistaken, pretty easy fix if it is I think, sure they're about £15 from VX or thereabouts.
    | Star Silver Corsa VXR | Milltek Turbo Back W/ Cobra Decat | Ramair Cone W/ Fog Light Air Feed | JS Performance Coolant & Intake Hoses | Airtec FMIC | 395cc Injectors | Forge Recirc | Walbro 255 fuel pump | Forge Subframe Brace | Boot Brace | 50mm H&R Springs W/ Bilstein Shocks | Mtech Short Shifter | Uniroyal Rainsports | Triple R Splitter | OPC Fog Surrounds | Mesh Lower Grille | RS Tuning Mapped | 233 BHP / 251 lb ft |

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts