+ Reply to Thread
Results 1 to 7 of 7
  1. #1
    VXRed
    Join Date
    19th April 2017
    Posts
    22

    Default Corsa D VXR interior fan/blower

    Hi everyone. For the last few weeks while travelling to/from work and having the fan on setting 2, i've noticed after about 10miles of driving, then pulling into my workplace carpark at around 5-10 mph the fan goes from fairly quiet to much louder (almost like setting 4 loudness). Once i park up it would quieten off again.

    However, tonight on starting my car to go to nightshift the fan has not come on at all, on any settings (1-4). I turned the car off and restarted thinking it would maybe reset, but nothing. I had to get a lift to work as windows in this weather are prone to misting up.

    Any ideas whats happened? I was thinking the fuse, but a faulty fuse surely wouldn't cause the fan to originally increase/decrease noise. Maybe its the actually fan?

  2. #2
    VXR enough
    Join Date
    23rd May 2013
    Posts
    2,113

    Default

    Could be the fan resister on its way out.

    Its common on these cars iirc.

    Cheap enough to diy fix

    Sent from my SM-N9005 using Tapatalk
    Corsa SRI Turbo and Facelift Corsa 1.4 SE

  3. #3
    VXR Nothing comes close VXRRy's Avatar
    Join Date
    15th May 2013
    Posts
    17,747

    Default

    Check your fuses, and if they are fine then check your resistor.

    If it's a manual air con then the resistor is cheap as chips


    Sent from my iPhone using Tapatalk

  4. #4
    VXRed
    Join Date
    19th April 2017
    Posts
    22

    Default

    Cheers guys. I'm off work next week so that'll be one of my 'to do jobs'.

  5. #5
    Are you VXR enough? iamphil's Avatar
    Join Date
    9th January 2017
    Posts
    795

    Default

    Same problem on my car last year, turned out it wasn't the heater resister but the actual blower motor itself, got a new one of Amazon for around £50.
    Silver Lightning Corsa VXR

  6. #6
    VXRed
    Join Date
    19th April 2017
    Posts
    22

    Default

    So turns out it was the resistor. £7.50 on ebay. What a pain to fit though. I consider myself a competent diy mechanic (ex aircraft engineer too) but this thing did my head in. The original came out fairly easy but i could not get the new one to slot in. Doesn't help trying to squeeze yourself under the glovebox to see either. Tried all angles to get in, pushing, forcing it. Just something not letting it fit in. Eventually compared it with the old one and one of the tabs on the side was in a different place. Trimmed that off with a knife. Still didn't fit. Then noticed four round tabs further up the body. One was in a different place. trimmed that off and 'click!', resistor finally fitted. A 10 minute job that took 2 hours. Dunno if it was because not official vauxhall, or may not specific to corsa d. At least its done now and i can drive this awesome machine once more.

  7. #7
    VXRacing ahead Brucerutherford's Avatar
    Join Date
    15th January 2014
    Posts
    646

    Default

    Quote Originally Posted by dogzombi View Post
    So turns out it was the resistor. £7.50 on ebay. What a pain to fit though. I consider myself a competent diy mechanic (ex aircraft engineer too) but this thing did my head in. The original came out fairly easy but i could not get the new one to slot in. Doesn't help trying to squeeze yourself under the glovebox to see either. Tried all angles to get in, pushing, forcing it. Just something not letting it fit in. Eventually compared it with the old one and one of the tabs on the side was in a different place. Trimmed that off with a knife. Still didn't fit. Then noticed four round tabs further up the body. One was in a different place. trimmed that off and 'click!', resistor finally fitted. A 10 minute job that took 2 hours. Dunno if it was because not official vauxhall, or may not specific to corsa d. At least its done now and i can drive this awesome machine once more.
    If you ever need to do it again, might be worth removing the glove box might help a little not too sure myself as never done it?

    two screws inside at the top and two underneath at the very bottom.

    At least it's sorted now though
    | Star Silver Corsa VXR | Milltek Turbo Back W/ Cobra Decat | Ramair Cone W/ Fog Light Air Feed | JS Performance Coolant & Intake Hoses | Airtec FMIC | 395cc Injectors | Forge Recirc | Walbro 255 fuel pump | Forge Subframe Brace | Boot Brace | 50mm H&R Springs W/ Bilstein Shocks | Mtech Short Shifter | Uniroyal Rainsports | Triple R Splitter | OPC Fog Surrounds | Mesh Lower Grille | RS Tuning Mapped | 233 BHP / 251 lb ft |

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts