+ Reply to Thread
Results 1 to 5 of 5
  1. #1
    VXR newbie
    Join Date
    3rd April 2018
    Posts
    2

    Default EGR alternative causes

    Hi,

    I came across your site from another forum, when I was looking for help with my Zafira - I hope someone can help.

    My Zafira has had an intermittent problem, with loss of power and kangarooing up the road. I thought it might be a blocked filter (or something blocked) as one minute it would not work and then the next it would be fine - especially if I parked up for a short while.

    I took it to a garage and they said they believed it was the EGR (read the fault code and it was one of two things - can't remember what the other was, other than it was to the left of the EGR in the engine), so they cleaned the EGR out. This didn't work and so I asked for it to be replaced; it was also serviced with filters replaced.

    It worked for a week and then I was parked up with the engine running for say 10 minutes, I went to go and stalled (don't know if that was my driving or the car) and then after that, there was virtually no power again. I turned it off for 5 minutes and it was fine. It was fine for 36 hours and then it started to slow down again, with no acceleration and then finally wouldn't move again. Stopped for 5 mins and then fine.

    I went online to look up the EGR and then rang the garage, as their pricing did not make sense. It turns out that they have replaced my EGR with a refurbished EGR and basically by-passed the EGR system, changing the software (an electrics guy was doing something to the car when I returned). He had been concerned about the cost of the genuine Vauxhall part and so worked around it.

    From what I have read, it seems to me in theory, that if it was an EGR problem, what they did should have worked. It also sounds like my car's action fit with an EGR problem?

    Online, I have read that the breather hose can get blocked up in the throttle body, which can also cause the same problems? Has anyone else had the same problem? Could you please let me know what was the cause in your case? Trying to solve it as really need my car on the road and it's really not safe, when it loses acceleration suddenly.

    Many thanks in advance - going back to the garage tomorrow, so any tips before then would be gratefully received.

  2. #2
    VXR newbie
    Join Date
    3rd April 2018
    Posts
    2

    Default

    Just in case someone else comes on here looking - it seems it was the MAF Sensor - totally clogged up with carbon.

  3. #3
    VXR Nothing comes close R15VXR's Avatar
    Join Date
    13th May 2008
    Posts
    21,617

    Default

    Quote Originally Posted by ZafiraZ View Post
    Hi,

    I came across your site from another forum, when I was looking for help with my Zafira - I hope someone can help.

    My Zafira has had an intermittent problem, with loss of power and kangarooing up the road. I thought it might be a blocked filter (or something blocked) as one minute it would not work and then the next it would be fine - especially if I parked up for a short while.

    I took it to a garage and they said they believed it was the EGR (read the fault code and it was one of two things - can't remember what the other was, other than it was to the left of the EGR in the engine), so they cleaned the EGR out. This didn't work and so I asked for it to be replaced; it was also serviced with filters replaced.

    It worked for a week and then I was parked up with the engine running for say 10 minutes, I went to go and stalled (don't know if that was my driving or the car) and then after that, there was virtually no power again. I turned it off for 5 minutes and it was fine. It was fine for 36 hours and then it started to slow down again, with no acceleration and then finally wouldn't move again. Stopped for 5 mins and then fine.

    I went online to look up the EGR and then rang the garage, as their pricing did not make sense. It turns out that they have replaced my EGR with a refurbished EGR and basically by-passed the EGR system, changing the software (an electrics guy was doing something to the car when I returned). He had been concerned about the cost of the genuine Vauxhall part and so worked around it.

    From what I have read, it seems to me in theory, that if it was an EGR problem, what they did should have worked. It also sounds like my car's action fit with an EGR problem?

    Online, I have read that the breather hose can get blocked up in the throttle body, which can also cause the same problems? Has anyone else had the same problem? Could you please let me know what was the cause in your case? Trying to solve it as really need my car on the road and it's really not safe, when it loses acceleration suddenly.

    Many thanks in advance - going back to the garage tomorrow, so any tips before then would be gratefully received.
    A VXR doesnt have a EGR - thats diesels only !

  4. #4
    VXR Nothing comes close R15VXR's Avatar
    Join Date
    13th May 2008
    Posts
    21,617

    Default

    Should however you have a non VXR Zaffy ie Diesel ...... you could have your car remapped and a plate put in its place which looks identical and far more beneficial to the vehicle in terms of power, economy and efficiency

    Only issue is if you are based in the UK the new MOT rules coming out in May 2018 - are hot on EGR valves and its an instant failure if they find a missing EGR unit

    You need advise from a Vauxhall Specialist not a stealer imo

    hth

  5. #5
    VXR Nothing comes close R15VXR's Avatar
    Join Date
    13th May 2008
    Posts
    21,617

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts