+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    VXR newbie
    Join Date
    19th April 2018
    Posts
    7

    Default Orange spanner warning light?

    Hi lads hope everyones ok,
    I recently bought a newish vxr (2012, 40k miles) off a local car garage and owned it about a month, ive got this orange spanner warning light twice (seperate times) when ive been giving it some beans. The first time i took it back to the garage who put it on the diagnostic tool thing and said their was no error code and it was simply a service light which they turned off. Couple of weeks later overtaking someone it came back on which has worried me. Any of you experienced fellas got any ideas why it came back on? Anything to worry about? Im just worried that if i take it back to the car dealership and they just turn the light back off again and i could be doing damage to my car. The car itself seems to run fine but i dont know if its been nakered since ive bought it and dont know any different. Any ideas would be great thanks 👍

  2. #2
    VXRed
    Join Date
    20th June 2017
    Posts
    154

    Default

    no it is not a service light and there will be a error code but there diagnostic tool is probably poor and it wont pick it up but if they erase the codes it will knock the light off for a bit

    the most common thing it comes on for is because the vacuum pipes pop off round the back of the engine so if you look at the side of the turbo there is a little pipe compared to the rest, follow it round the side of the engine to the back is goes into a little boost controller there are 3 pipes that go into it check make sure none of them have popped off

    2 of the pipes of that controller go into a square vacuum box next to it, check they have not popped of either

    if you get the car in the air you can see both of those things a lot easier

    by the sound of things you say it comes on when you are putting the car under load and you say it feels fine so I would just say it was a leak somewhere

  3. #3
    VXR newbie
    Join Date
    19th April 2018
    Posts
    7

    Default

    Cheers for the reply mate, ill see if i can see anything that has come off under the bonnet today. Do you reckon its worth sacking off getting it done for free at the garage i bought it at and go somewhere else then? Also will it be doing any damage to my car driving it without it being fixed? Thanks again

  4. #4
    VXR enough
    Join Date
    23rd May 2013
    Posts
    2,059

    Default

    Quote Originally Posted by Fx rob View Post
    Cheers for the reply mate, ill see if i can see anything that has come off under the bonnet today. Do you reckon its worth sacking off getting it done for free at the garage i bought it at and go somewhere else then? Also will it be doing any damage to my car driving it without it being fixed? Thanks again
    Yes, avoid that garage as they're pulling a fast one.

    Go somewhere different, or at least that has proper diagnostic kit and not some 5.99 reader off ebay.

    Hard to say if its causing damage...if its vacuum pipes it won't be but nobody can tell you for certain over the internet.
    Corsa SRI Turbo and Facelift Corsa 1.4 SE

  5. #5
    VXR newbie
    Join Date
    19th April 2018
    Posts
    7

    Default

    Right yeah ill take it somewhere else, cheers for the reply lads. So basically that orange spanner warning light could be a whole range of different things and not specific to a certain part of the engine/car?

  6. #6
    VXRed
    Join Date
    20th June 2017
    Posts
    154

    Default

    it could be but like I said if it comes on when you give it some beans I would say it would be boost or vacuum

    did you have a look at the pipes round the back

  7. #7
    VXR newbie
    Join Date
    19th April 2018
    Posts
    7

    Default

    I had look pal, with my zero knowledge of engines i didnt really know what to be looking at but them 3 hoses together seemed attached. I did see a hose come out of the turbo that wasnt attactched to anything, could this be the problem? hope this image works hah. https://ibb.co/dtRJu7

  8. #8
    VXRed
    Join Date
    20th June 2017
    Posts
    154

    Default

    no that pipe is from your air filter box but to the right of that have a look for a little pipe, looking at it you might think its a cable but it goes round to the back of the engine on the top left the pipe will probably be a cream colour

  9. #9
    VXR newbie
    Join Date
    19th April 2018
    Posts
    7

    Default

    I found that cable mate and it seems like its still attached.
    Researching and finding the turbo (i think) the rubber hose underneath it is really really soft, could that be the cause of the error? When im full accelerating instead of sending the air to the engine its inflating the hose like a balloon instead? Again i have no clue just trying to think of problems haha https://ibb.co/gNbrgn

  10. #10
    VXRed
    Join Date
    20th June 2017
    Posts
    154

    Default

    that pipe may be attached but to the right of that pipe at the back of the engine there is a black box with two pipes coming out of it they pop off too

    where about are you based

    you need to get it on a proper diagnostics to get the code and then we wouldn't be guessing lol

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts