+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    VXRed
    Join Date
    18th April 2016
    Posts
    176

    Default (Help!!!)Has this happened to anyone before

    I need help!!!

    Hi guys
    So today I went fast show , driving the car fine no slippy clutch or anything like that.then all of a sudden, Iím struggling to get the car into gear .queuing to get into the show it doesnít want to go into first gear so have to drive in second gear with much force .at a stand still clutch down and in gear 2 the car still very slowly wants to move forward (level ground)

    Managed to get home the car drives no different when itís in gear as when the cars off it goes into all gears

    Before it goes to wg motorworks I just want second opinions as to what you guys think it could be ,(stage 2 clutch and flywheel last year,

    Appreciate any help coming this way

    Danny

  2. #2
    VXRed blooded
    Join Date
    11th July 2017
    Posts
    292

    Default

    sounds like a master or slave failure or some similar clutch system leak.
    if the underside of the bell housing is bone dry then the seals in the master may have died.
    Does the pedal travel normally of just drop to the floor

  3. #3
    VXRed
    Join Date
    18th April 2016
    Posts
    176

    Default

    Quote Originally Posted by genman View Post
    sounds like a master or slave failure or some similar clutch system leak.
    if the underside of the bell housing is bone dry then the seals in the master may have died.
    Does the pedal travel normally of just drop to the floor

    It travels normally but since this is happened the clutch isnít as stiff to normal stage 2 clutch now

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts