+ Reply to Thread
Results 1 to 6 of 6

Thread: Fuel Pump

  1. #1
    VXRed
    Join Date
    5th March 2017
    Posts
    23

    Default Fuel Pump

    Hi everyone,... I dont have a VXR I know .. :P

    I've got the SRI 200 and i'm wondering if you guys know do we share the same fuel pump setup?

    Every now and then my car will drop all acceleration and hesitate for a second then back to normal, i'm presuming its the fuel pump on the way out.

    Now I'm currently trying to sell the car and I don't really want to put a 300 quid OEM pump setup in it, can you strip the old pump out of the whole setup and just plug and play?? Pumps seem to cost a lot less than the Vauxhall setup.

    Any ideas as i'm at a bit of a loss here with information on what pump they actually use.

    Cheers

    Chris

  2. #2
    VXRed
    Join Date
    5th March 2017
    Posts
    23

    Default

    Have any of you changed the pump in your in tank housing?

  3. #3
    VXRed blooded Rksmith's Avatar
    Join Date
    15th December 2016
    Posts
    397

    Default

    Have your tried injector cleaner. Or red x fuel system cleaner? Might be a bit of dirt in the system. Pick them up from Halfords


    Sent from my iPhone using Tapatalk

  4. #4
    VXRed
    Join Date
    5th March 2017
    Posts
    23

    Default

    Yeah I used some red X a few weeks before any problems due to it being on offer,.. Think ill go check if anyones got this BG44K stuff in as its coming up as the best stuff in reviews,
    Cheers mate

  5. #5
    VXRed
    Join Date
    5th March 2017
    Posts
    23

    Default

    I think its running better after I used some Wynn's Gold, will see how much fuel and stuff it uses now maybe just all needed a clean out like you said.

  6. #6
    VXRed blooded Rksmith's Avatar
    Join Date
    15th December 2016
    Posts
    397

    Default

    Quote Originally Posted by SriGuy View Post
    I think its running better after I used some Wynn's Gold, will see how much fuel and stuff it uses now maybe just all needed a clean out like you said.
    That’s good to hear mate hopefully that sorts it out.


    Sent from my iPhone using Tapatalk

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts