Closed Thread
Results 1 to 2 of 2
  1. #1
    VXR newbie
    Join Date
    27th June 2018
    Posts
    5

    Default Deleted Post

    Hi, I have an Insignia 2.0 T petrol not the VXR, it's a similar engine to the Astra J VXR. I've spent a lot of time diagnosing an issue that didn't throw a DTC. The VVT Cam Solenoid on the Intake side was seized but was fine electrically. I managed to clean it and free it up and the car drove 10 times better, but it didn't last. I bought a replacement pair and this is where the trouble started, whoever replaced these in the past had put them on the wrong way around, the exhaust solenoid was operating the intake side and vice versa, I've triple checked it. I wasn't sure which wire went to which solenoid now as the connector was identical, so I left one off to throw a circuit open DTC which worked and double checked with the other one, it was indeed wired the wrong way.

    Now I'm confident everything is installed correctly and wired up right but when I turn the ignition on the Service Vehicle Soon message pops up and doesn't go away, the car is also in a kind of limp mode, feels like a max of 50hp. I've tried clearing the DTC codes but they come back. I've tried swapping the connectors back over, even reverting it to the state it was before I started, but it still throws the DTC codes that I introduced to it and stays in limp mode with the Service Vehicle Soon message displayed.

    I have no idea how to reset this, Google didn't help me much. Anyone have any idea? I feel like the ECU remembers the circuit open fault despite it no longer existing, and needs to be reset.

    Cheers,
    Tom

    tl;dr: how do I tell the ECU the problem's been fixed and it's safe to come out of limp mode?
    Last edited by IanJ; 14th July 2018 at 01:54 AM.

  2. #2
    VXRed blooded
    Join Date
    11th July 2017
    Posts
    319

    Default

    have you tried old faithful.... disconnect the battery negative for 30minutes or so... usually clear old codes.

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts