Announcement

Collapse
No announcement yet.

19" Dilema! URGENT

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 19" Dilema! URGENT

    Another problem!

    Due to a couple of days hard driving and bit of lazzyness, I let my baby go a few days without a wash! (ok-9days to be exact - dont shout at me)

    To which, my front wheels had some really stubborn brake dust WELL on there.

    I tried to wash as normall but wouldnt come off. So I went to buy some Turtle Wax Wheel Clean. I followed the instructions perfectly (as you do)
    and all seemed to be lovely an new. Back to normal.

    After going and taking a seat for a couple of hours I went out to have a wee look and to my absolute disgust The front drivers wheel seems to be Damaged in some way? I dont know if its the paint thats come off or if it was the product that has just stained the wheel! But i tried cleaning it all over again and nothing has changed.

    can anyone share their experience or just advise what I should do!
    I.E Claim turtle wax or see the dealer for giving me a doggy wheel

    This is so frustrating? None of the other 3 wheels are the same.

    All fine apart from the front drivers side.

    Cheers

  • #2
    Hmmm....I know that someone had a issue with no laquer (sp?) on one or two wheels. Both were replaced under warrenty. Ask your dealer get it checked.

    I've no idea if this is the case with yours but you never know.

    Comment


    • #3
      I had a similar problem when i had the scooby, i left the cleaner on the wheel too long and its stained the wheel (not that thats what you did) but no amount of washing would remove it. Sounds like it might be an issue with the wheel though as it was only one of the four. I would try your dealer first.

      Comment


      • #4
        I thought that I could have left it on too long? But I didnt do anything different to what I did with the other 3 of them.

        Plus I have used this product on my two previous mini's and never had that?

        So frustrating. Only had it 2 months!

        So it could be missing laquer? How can you tell that by looking at the wheel?

        Does it strip the paint or does it look as though its just a white stain?

        Comment


        • #5
          Mine just turned white Ian, looked pretty bad.
          "Luckily" for me I hit a pothole and knackered the wheel and tyre the following week so had to buy a replacement anyway

          Comment


          • #6
            Originally posted by m4rtc
            Mine just turned white Ian, looked pretty bad.
            "Luckily" for me I hit a pothole and knackered the wheel and tyre the following week so had to buy a replacement anyway
            Ouch!!!

            How much was that then?

            Comment


            • #7
              kool kool

              I have the car going in this afternoon for them to have a look at the wheels. See if its something they can do under warranty!

              Fingers Crossed!

              Oh, what are they likely to do?

              Replace the wheels or just re-paint them?

              Ian

              Comment


              • #8
                Originally posted by alex_c
                Originally posted by m4rtc
                Mine just turned white Ian, looked pretty bad.
                "Luckily" for me I hit a pothole and knackered the wheel and tyre the following week so had to buy a replacement anyway
                Ouch!!!

                How much was that then?
                Cant remember exactly, i think it was about £350 all in but that was for the Subaru so i dont know what the damage would be for the vxr :?

                Comment


                • #9
                  Anyone else had problems with this?

                  Comment


                  • #10
                    Twas me who had laquer (or lack of ) issues with both my front 19"s.
                    My problem was basically that despite thorough cleaning - the brake dust had penetrated the alloys and wouldnt shift no matter what product I used. Turned out that the laquer was virtually non existent on 3/4 of the surfacer areas of both wheels. VX sent a field engineer up to my local dealer who took one look and ordered 2 replacements - job done

                    Incidently - I now use an alloy wheel wax from a reputable Alloy refurbisher up in the Midlands and have had no problems since and the muck just falls off when washing em!

                    Comment

                    Working...
                    X