Announcement

Collapse
No announcement yet.

Stage 3 won't boost more than 15psi???

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stage 3 won't boost more than 15psi???

    Hi i'm having trouble with the boost on my car it's running stage 3 thorney map with hybrid turbo it will not boost no more than 15psi, I have replaced the afm and map sensor made no difference I have even wound the actuator up that also made no difference, I have tried standard map and it only made 6 psi, I have checked all the vacume pipes and boost pipes all looks fine I'm confussed now don't no wat else to try any 1 got any ideas or come across this problem ??

  • #2
    Originally posted by Vxrpow View Post
    Hi i'm having trouble with the boost on my car it's running stage 3 thorney map with hybrid turbo it will not boost no more than 15psi, I have replaced the afm and map sensor made no difference I have even wound the actuator up that also made no difference, I have tried standard map and it only made 6 psi, I have checked all the vacume pipes and boost pipes all looks fine I'm confussed now don't no wat else to try any 1 got any ideas or come across this problem ??

    Have you tried TMS support ?
    sigpic

    Comment


    • #3
      Yeah they just say bring the car up to them but I'm not able to do that.

      Comment


      • #4
        I think you need to get the car checked over and the only way to find the issue maybe a trip to TMS

        It appears you are guessing and replacing parts that you think it is and wasting money - the car need to be checked over by someone who have the right equipment and knowledge.

        Comment


        • #5
          Have you had any diagnostic equipment on the car and checked what the onboard map and throttle sensors are reading?

          Comment


          • #6
            Yeah I have had the scanner on whilst driving to check the throttle is not closing, I toke the map sensor out anx blanked the hole off went down the road and it over boosted and pulled hard to 24 psi so that y I replaced the map sensor but when I put the new 1 in it made no difference lol

            Comment


            • #7
              have you checked the internal dump valve.
              Check out our new website sign in for discounts

              www.ntjmotorsports.co.uk
              ..

              Comment


              • #8
                I think you're going to have to take it to tms or at least somebody that can run a full diagnostic.

                Comment


                • #9
                  How do u check the internal dump valve ? I can't get the car to tms !

                  Comment


                  • #10
                    No fault codes come up on the bluefin unit or snap on scanner

                    Comment


                    • #11
                      Originally posted by Vxrpow View Post
                      No fault codes come up on the bluefin unit or snap on scanner
                      So you have not connected it to tech2, this is the only defiant way of finding out what is wrong.

                      Why can you not go to TMS, too far ? maybe you could go to a tms performance centre - http://www.thorneymotorsport.co.uk/p.../home-pc.shtml

                      Comment


                      • #12
                        take it out and check the diaphram for tears rips ect
                        Check out our new website sign in for discounts

                        www.ntjmotorsports.co.uk
                        ..

                        Comment


                        • #13
                          can i borrow your MAF please....

                          Comment


                          • #14
                            Can you read what the map sensor is seeing to confirm its actually reading right? Might be a wiring issue or scaling issue on the map?

                            Independent bespoke mapping available see my Facebook or find me at WG Motorworks

                            Clique #14

                            Comment


                            • #15
                              Ok I will get it looked at on tech 2 think that might be a good option, tms are not open Saturdays and I work during the week, if the internal diaphram is split or perished would it still get 15psi and hold it ? Just was not sure if this was a problem that u lot have come across before, before I spend loads of money in a garage

                              Comment

                              Working...
                              X