Announcement

Collapse
No announcement yet.

Help :(

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help :(

    My car has started to make a strange whistle on idle, can't seem to make out where from tho . Any one have any ideas? Thanks

  • #2
    boost leak? check all hoses
    Remus turbo back , TX enlarged tophat, CDTI pipework, Pipecross XL Foam/Cone Filter, FMIC, Forge recirc valve, Forge actuator, Regal 3 bar map sensor, HRC fuel pump, Courts coolstat , GM Breather box, custom oil catch can, FK coil overs, Whteline RARB Gloss Black Corsa VXR Alloys, De badged and de-wiper at rear. HID headlights/LED sides. Custom carbon wrapping.

    Comment


    • #3
      Thanks mate.. I have tx intercooler and top hat and power pipe and dump valve.. Is it all these I need to check? Sorry about silly question

      Comment


      • #4
        Yes mate best bet is to check them all tho, make sure u check all the turbo hoses including the vacum hoses all the way down to the box
        sigpic3" Full Scorpion System, 1.9 cdti box, K&N Filter, Steinmetz Top Grill, Custom maps frm San Speed, 18" White Alloys, Blue Turbo Hose Kit, Vacuum Hose Kit, and Intake Hose Kit, Forge diviter valve, Boost Gauge(psi), Boost temp gauge, TXA Plenum, voltage staberlizer, debadged rear with white vx(r). Quaife LSD, White Plug cover with blue vx(r), Torque app for my phone, Vec C intKe pipe, Chrome Battery cover and heat shield

        Comment


        • #5
          Ok mate, thanks. It's really annoying does my head in

          Comment

          Working...
          X