Announcement

Collapse
No announcement yet.

1st Service Problems

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1st Service Problems

    Just had my first service and although no major problems one of the brack discs is badly scored. I have only done 11,000 miles and its not been on the track or driven too hard. Obviously this isnt covered by warrenty but there must be a problem for one disc to be in such bad condition so soon. Any advice to potential causes.

    Also had an oil leak on the turbo but all covered by warrenty.

  • #2
    I had the same problem with the brake disk on my old tigra. I took the pads off and found that there was some dirt stuck between the pad and disk so it started to eat at the disk.

    Comment


    • #3
      hi ben no prob's with the disc's but i also had a leaking turbo a lot as to do with the grade of oil used as it's too thin did they put the 5/30 back in for you ?
      sigpic
      stealth no more but beware of the silver lightning GSI with vxr power
      M.U.F.C.
      http://www.courtenaysport.co.uk/

      Comment


      • #4
        Hi mate had my car in to the stealers for the same thing thay tryed it on to start with, by saying i could be crap thats been picked up in the pads but as i told them i had the pads out and it was down to what looked like big bits of brass in the pad thay changed all 4 disks and pads.

        www.courtenaysport.co.uk/ For all your tuning needs

        Comment

        Working...
        X