Announcement

Collapse
No announcement yet.

Any one fitted one of these?

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Any one fitted one of these?

    Fitted a dump valve yesterday and ordered this. Any got it fitted to their VXR and would it do any damage to my turbo

    http://www.forgemotorsport.co.uk/con...roduct=FMBPVXA

    also does anyone know if this would fit on the VXR, i have the standard hoses

    http://www.carperformanceuk.co.uk/as...-pr-21107.html

    cheers dan
    Tech 2, Cruise Control, Anti Hijack, Check Control, Board Computer And Divorce & Marry New Radios & Screens In & Around SouthWest London/Heathrow Airport. Pm For Info

  • #2
    wont damage your dump but "may" cause a fault to come up usally boost leak codes, as it will be dumping all messured air. with the oe in place the after market dump valve doesnt dump all the air. doesnt allways happen but if it starts playing you know its that

    Comment


    • #3
      that fitting kit wont fit either as its for the mk4 astra and the pipes are different
      Quaife LSD . . Milltek/Powerflow Turbo back exhaust . . Custom Intercooler . . Percy 1.9 Cdti airbox . . Whiteline RARB . . Collins dump valve . . Courts enlarged top hat/power pipe . . Oil Breather Box . . cruise . . anti-hijack . . check control . . Blue SMD conversion . . wind deflectors . . opel numberplate surrounds . . pressed plates . .

      Comment


      • #4
        also dont think it will fit the hoses sure there slighty smaller than vxr, i just cut my OE hoses and put big T-piece in place as in the fitting kits you get

        Comment


        • #5
          cheers, yer thts wot ive done, but doesnt really look very nice and the T piece i got with the dump valve is abit smaller than the hose, spoke to Roosemotorsport, to my door for the VXR hose its £42 so might go ahead and order that tonight
          Tech 2, Cruise Control, Anti Hijack, Check Control, Board Computer And Divorce & Marry New Radios & Screens In & Around SouthWest London/Heathrow Airport. Pm For Info

          Comment


          • #6
            Originally posted by whytie-vxr View Post
            that fitting kit wont fit either as its for the mk4 astra and the pipes are different
            beat me lol

            Comment


            • #7
              Courtney sell a dump valve take off pipe think its about £55 i had boost sensor problems when i first fitted mine until i reset the ECU and its been fine ever since!

              Comment


              • #8
                well fitted this last night, a feels the turbo is holding bk a little at low revs, but when it kicks in it seems to pull quicker - think its just me being paranoid. when idling its making a funny sucking / choking noise from the air filter and somethimes when dumping it make a noise similiar to the "turkey noise" but ive checked all the vacuum pipes and none are leaking/poped off and there doesnt seem to be any ait escaping from where the old oe dv was. tt-vxr was this what was happening to you, i will get it plugged in tonight, but when you say you had your ecu reset what exactly did u do to rest it?
                Tech 2, Cruise Control, Anti Hijack, Check Control, Board Computer And Divorce & Marry New Radios & Screens In & Around SouthWest London/Heathrow Airport. Pm For Info

                Comment


                • #9
                  Originally posted by mannan6 View Post
                  well fitted this last night, a feels the turbo is holding bk a little at low revs, but when it kicks in it seems to pull quicker - think its just me being paranoid. when idling its making a funny sucking / choking noise from the air filter and somethimes when dumping it make a noise similiar to the "turkey noise" but ive checked all the vacuum pipes and none are leaking/poped off and there doesnt seem to be any ait escaping from where the old oe dv was. tt-vxr was this what was happening to you, i will get it plugged in tonight, but when you say you had your ecu reset what exactly did u do to rest it?
                  I had 3 error codes after driving about an hour about boost pressure etc etc. I reset my ECU by disconnecting the live on the battery for 15-20 mins iv never had a problem since. and its done around 1000 miles with it fitted my car makes funny noises sometimes but there always different i dont think it has anything to do with the dump valve

                  Comment


                  • #10
                    cheers mate, il chk for errors, when i get home ... mines the same always abit diff, but gets drowned out by the swooosh did u ever get the feeling ur turbo was kiking in about 500revs higher?
                    Tech 2, Cruise Control, Anti Hijack, Check Control, Board Computer And Divorce & Marry New Radios & Screens In & Around SouthWest London/Heathrow Airport. Pm For Info

                    Comment


                    • #11
                      Originally posted by mannan6 View Post
                      cheers mate, il chk for errors, when i get home ... mines the same always abit diff, but gets drowned out by the swooosh did u ever get the feeling ur turbo was kiking in about 500revs higher?

                      that "could be" because you turbo is stalling more, not getting the air out quick enough. so it takes longer for it to spin up when put foot back on the gas, ie more lag.

                      bet the noise is alot better tho, but if you want less lag would of been better to left the OE in play as well, as then it can dump the air quicker resulting less turbo stall.
                      if your dump valve is second hand check it for leaks as with time they get dirty dont move as freely causing boost leaks etc.

                      if you got boost codes pop up, could be a few things,
                      its dumping to much air ecu messures the air then all of a sudden its gone so it get confused.
                      or and its leaking some where.

                      steps to sort it out be disconnect battery 15mins reset it,
                      codes still pop up or it not right check boost leaks, and clean dump valve if second hand.
                      still no luck put the OE back in play reset ecu again
                      Last edited by beefycol; 9 October 2009, 02:58 PM.

                      Comment


                      • #12
                        Originally posted by mannan6 View Post
                        cheers mate, il chk for errors, when i get home ... mines the same always abit diff, but gets drowned out by the swooosh did u ever get the feeling ur turbo was kiking in about 500revs higher?
                        Turbo seems to be kicking it at the same point it was before matey

                        Comment


                        • #13
                          i'm still getting the funny turkey like noise, checked all the pipes and there doesnt seem to be a split anywhere or nothing seems to of poped off. i got the below 4 ECN error codes

                          23505
                          124538 but i have a feeling i meant to write down 124358
                          53006
                          11014
                          00000

                          any ideas what can be causing this? i know ones to do with aircon which i alreday know about - Unplugged sensor
                          Tech 2, Cruise Control, Anti Hijack, Check Control, Board Computer And Divorce & Marry New Radios & Screens In & Around SouthWest London/Heathrow Airport. Pm For Info

                          Comment


                          • #14
                            Originally posted by mannan6 View Post
                            i'm still getting the funny turkey like noise, checked all the pipes and there doesnt seem to be a split anywhere or nothing seems to of poped off. i got the below 4 ECN error codes

                            23505
                            124538 but i have a feeling i meant to write down 124358
                            53006
                            11014
                            00000

                            any ideas what can be causing this? i know ones to do with aircon which i alreday know about - Unplugged sensor
                            codes here http://www.vxronline.co.uk/forum/showthread.php?t=33644

                            i cant work your codes out out must be drunk dont seem to match.
                            reset ecu. see if codes come up again. sounds to me as if blocking the oe dump valve causing these probs

                            Comment


                            • #15
                              cheers was tryna find sumin like tht but couldnt find it, these are the ones that come up wen i pres the break and accelerator pedal and turn the ignition on, for some reason they dnt come up wen my laptop is plugged in :s
                              Tech 2, Cruise Control, Anti Hijack, Check Control, Board Computer And Divorce & Marry New Radios & Screens In & Around SouthWest London/Heathrow Airport. Pm For Info

                              Comment

                              Working...
                              X