Announcement

Collapse
No announcement yet.

How Many of you ......

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How Many of you ......

    Have had TMS stage 2 done and EML came on with 042011 error code?

    Also, how many of you have tried to fix it with no success or just decided to drive with the EML on?

    Cheers, Silver.

    PS NO tuner war PLEASE!
    Last edited by SilverSchoolBus; 4 November 2009, 08:04 PM.
    Zaffy VXR| RARB | Vxracing 19s in Gloss Black |Stage 3丨Turboback Miltek 丨TX Intercooler丨CDTI set-up with Pipercross Open Cone丨Forge Recric Valve 丨 Debaged 丨Corsa Indicator Surroundings |Full Rear Sunblinds | Leds Footwell Lightings丨

  • #2
    ive had this fault code before,but it only flashed for a second then went back to 0000000 an now it dosnt show at all.i never changed or done anything so its a small fault that exists with performance exhausts.i think its to do with emissions
    sigpic

    Comment


    • #3
      I had a couple flash up the other day, car went into limp mode. I pulled over, turned it off. Left it a few seconds, flashed the codes up with the pedal thing. Turned it back on, no EML light and no issues with performance.

      Weird.
      I have a difference of opinion to you.

      Comment


      • #4
        To be honest, Most if not all performance exhausts have the same problem, even more so if the car is mapped, Mine has come up a couple of times and once i check what it is I just clear it.

        I think the zaf's and astra's must have a very small tolorence for emission values and so as soon as the sport cat is fitted it notices somthing isnt right and throws up the code.

        It will pass an MOT fine mate.

        Comment


        • #5
          Originally posted by Ojc View Post
          I had a couple flash up the other day, car went into limp mode. I pulled over, turned it off. Left it a few seconds, flashed the codes up with the pedal thing. Turned it back on, no EML light and no issues with performance.

          Weird.
          That is my fear, lol. As long as I am not damaging things and it doesn't put itself into "limp mode", I suppose I can live with the little light on the dash, lol. However, it would be nice to find the problem and fix it!
          Zaffy VXR| RARB | Vxracing 19s in Gloss Black |Stage 3丨Turboback Miltek 丨TX Intercooler丨CDTI set-up with Pipercross Open Cone丨Forge Recric Valve 丨 Debaged 丨Corsa Indicator Surroundings |Full Rear Sunblinds | Leds Footwell Lightings丨

          Comment


          • #6
            had this on mine took map of and put stage 2 back on ok now had this 2 times know

            Comment


            • #7
              There is one way to fix this but you will then never now if the cat fails

              To block the o2 sensor or put a de-cat map on then the light and code wont come up

              Comment


              • #8
                P0420 Cat System Efficiency Below Threshold can occur on cars running a high flow sports cat, usually 100 cpi, but sometimes 200 cpi. More usually this occurs on cars running OE software than on remapped cars, (depending on which software is being used on a mapped car).

                On a standard mapped car, because a sports cat is higher flowing, and so filters out fewer of the 'nasties' the second lambda sees higher emissions readings than it is expecting to see, because it is using lookup tables written for a map written for use with a much denser catalyst i.e. an OE cat which will produce fewer emissions. So the EML comes on for P0420

                On a remapped car if the P0420 DTC is written out of the map or the thresholds are correctly altered then the EML will not come on for this P0420 fault code.

                Simples! (All the above assumes that an O2 sensor has not been damaged during exhaust fitment)

                Comment


                • #9
                  Originally posted by andriano View Post
                  There is one way to fix this but you will then never now if the cat fails

                  To block the o2 sensor or put a de-cat map on then the light and code wont come up
                  Thanks for the solution but hmmmmmm, i am not too sure about that, lol.
                  Zaffy VXR| RARB | Vxracing 19s in Gloss Black |Stage 3丨Turboback Miltek 丨TX Intercooler丨CDTI set-up with Pipercross Open Cone丨Forge Recric Valve 丨 Debaged 丨Corsa Indicator Surroundings |Full Rear Sunblinds | Leds Footwell Lightings丨

                  Comment


                  • #10
                    Originally posted by SilverSchoolBus View Post
                    Thanks for the solution but hmmmmmm, i am not too sure about that, lol.
                    Good to be a help.

                    I dont see what you could loose by blocking the O2 sensor but i would go careful and speek to the tuners about the de-cat map though before putting it on, if you are thinking about that

                    Comment


                    • #11
                      Originally posted by andriano View Post
                      speek to the tuners about the de-cat map
                      Exactly as I said! If the map has been done correctly, whether the exhaust does or does not have a cat, that error will not bring the EML on. If TMS can't do it I know Courtenay or EDS can.

                      Comment


                      • #12
                        Originally posted by VX220T View Post
                        Exactly as I said! If the map has been done correctly, whether the exhaust does or does not have a cat, that error will not bring the EML on. If TMS can't do it I know Courtenay or EDS can.
                        Exactly, too, lol, all they (the programmers) have to do is just increase the tolerance further, if it was +/-5, how about +/-10, that should stop the code and eml coming up and I can't see what sort damage it can do to the car apart from it is not too obvious to spot a failed cat, well, the mot tester would let me know that I suppose, lol.
                        Zaffy VXR| RARB | Vxracing 19s in Gloss Black |Stage 3丨Turboback Miltek 丨TX Intercooler丨CDTI set-up with Pipercross Open Cone丨Forge Recric Valve 丨 Debaged 丨Corsa Indicator Surroundings |Full Rear Sunblinds | Leds Footwell Lightings丨

                        Comment


                        • #13
                          Ive the same map and not had it mate.

                          Ive got the remus exhaust if that helps and it was on it a year before i put the map on it.

                          I have had bother with the O2 before but it went away. Only happend when the car had been sitting idling for ages then i took off and the light came on but that was before i mapped it. Its been fine touch wood since i mapped it. I did have bother with a boost solinoid and air flow meter but replace them and car is perfect.

                          Comment


                          • #14
                            was a big problem on my car...stage 1 2 and 3 but tms/superchips sorted it
                            WARNING all replys are incorrect as usual

                            Comment

                            Working...
                            X