Announcement

Collapse
No announcement yet.

turbo problems!! please help :( !

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • turbo problems!! please help :( !

    My car has had a new turbo fitted it boosts fine sometimes throughout all gears, but every now and again it dies no boost and locks out at about 5krpm. And then there's no boost atall after that untill I turn car off and leave it be for a few minutes been pluged into diagnostics and nothing comes up!!
    Anyone had this problem or no wat it cud be??

  • #2
    i'd take it bk to who ever fitted the turbo. sounds like its going to limp mode then clears after you turn the car off.

    Comment


    • #3
      Take it to the dealers mate tell them to test it with a boost gauge then they will see..

      Comment


      • #4
        Any you modded in anyway?

        Comment


        • #5
          i am of course assuming you are standard and your turbo was fitted by VX .. if not ignore my comment

          Comment


          • #6
            Could be as elsewhere that the actuator isn't set up correctly.

            But as above, garage is your best bet.
            Originally posted by Bobbyp90
            Yes Tom! You're a freaking genius!
            sigpic
            Corsa "user guide" , VXR Car Game
            South East Regional Organiser

            PSN: TomFL12

            Comment


            • #7
              No its not standars stage 1 map. Had it put on a dyno today and the power loss is unreal! Nearly half the power it was wen it was first done. Had the solenoid changed so maybe actuator??

              Comment


              • #8
                sounds to me like the actuator needs setting up properly

                Corsa VxR 07 Plate = Stage 3 Beast

                Comment


                • #9
                  had that done now as well....its still doing it! it's frying my brain lol i don't understand what it could be, 3 different code readers have been plugged it not one fault code has come up !!

                  Comment


                  • #10
                    have you tried runnin the car up to when it basically runs out of puff to when the problem kicks in then plug the diagnostic to check........i dont know if thats possible im just thinking before you turn the car off it might holds the codes if its resetting its self after you turn it off.

                    Corsa VxR 07 Plate = Stage 3 Beast

                    Comment


                    • #11
                      Don't suppose it could be the lamda sensor? Are you running a non standard cat? (decat/sports cat)

                      Comment


                      • #12
                        yeah drove with the code reader in for a bit to see if anything came up, i didn't. also had it put on a dyno today down got boost performance and came back with only one problem wich was the lack of boost. Thinking of sending it to a specialist maybe, cant seem to pin point the problem so it could be more complicated than it seems

                        Comment


                        • #13
                          Bloody turbo'd cars.....pain in the back side lol. Hope you get it sorted pal, please post up the results to help anyone with similar problems bet your pulling your hair out aren't you?

                          Comment


                          • #14
                            When you say it locks out at 5rpm do you mean it won't rev any further..
                            It sounds stupid but I had this happen once and I tried everything and was finally traced to the wiring not plugged into my air flow meter.. The plug was on but the wire had not connected inside.. It was like hitting a wall it revved and then just stopped dead.. Worth a look I'd say.. Hope you get it sorted..

                            Comment


                            • #15
                              stage 1 remap.. ? tuner? handheld?
                              Have you had back to standard to see if it still does it?

                              Comment

                              Working...
                              X