Announcement

Collapse
No announcement yet.

Corsa Burg squealing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Corsa Burg squealing

    Hi guys,

    So I'm running out of ideas..

    Owned my 63 plate Corsa VXR Nurburgring, for a few months, and since getting it, I've noticed like a screeching sound, which I assume is coming from the back wheels..
    Being that this car is full warranted by toyota (got a friend there) I've let them do all the work till now..

    So the problem is, at say, 10-40mph, when slightly turning the steering wheel right, say.. between 5 and 10 degrees at these speeds I get like a noise, like something on the disc is catching somewhere.. sounds like a screech (not a metal on metal).

    So it's been in and out of the garage for investigation and everytime I've showed them, they've been confused as to what could be causing it. So it's had brand new brembo discs and pads on the front, it's had brand new Pagid discs and pads on the back.. and I'm still getting this problem.. after fitting the back set, the problem seemed to go away for a few days, but then returned.

    Have to say, I noticed this happens when the cars is up to temp, and brakes have been applied a few times. If I stop, then drive off again, the noise will go until the cars warm again.
    This was happening before the brand new brakes and pads, and is still occurring. I told them to copper grease the back, which they did, and I can only assume that's worn off and the squeal has come back.

    I'm no greasemonkey, but I've had a look at everything looks as it should, I can't really see any points of contact, and neither can the toyota techs.

    Any help, suggestions or questions would be greatly appreciated gents, as I'm really at my wits' end here..

    Tia,
    Corsa VXR Nurburgring
    White

  • #2
    Originally posted by EL_Azz0 View Post
    Hi guys,

    So I'm running out of ideas..

    Owned my 63 plate Corsa VXR Nurburgring, for a few months, and since getting it, I've noticed like a screeching sound, which I assume is coming from the back wheels..
    Being that this car is full warranted by toyota (got a friend there) I've let them do all the work till now..

    So the problem is, at say, 10-40mph, when slightly turning the steering wheel right, say.. between 5 and 10 degrees at these speeds I get like a noise, like something on the disc is catching somewhere.. sounds like a screech (not a metal on metal).

    So it's been in and out of the garage for investigation and everytime I've showed them, they've been confused as to what could be causing it. So it's had brand new brembo discs and pads on the front, it's had brand new Pagid discs and pads on the back.. and I'm still getting this problem.. after fitting the back set, the problem seemed to go away for a few days, but then returned.

    Have to say, I noticed this happens when the cars is up to temp, and brakes have been applied a few times. If I stop, then drive off again, the noise will go until the cars warm again.
    This was happening before the brand new brakes and pads, and is still occurring. I told them to copper grease the back, which they did, and I can only assume that's worn off and the squeal has come back.

    I'm no greasemonkey, but I've had a look at everything looks as it should, I can't really see any points of contact, and neither can the toyota techs.

    Any help, suggestions or questions would be greatly appreciated gents, as I'm really at my wits' end here..

    Tia,
    I had a problem similar to yours and it turned out to be the rear beam bushes, this was found by putting the car on a shaker and on a ramp at an mot station then you could hear the exact noise I was getting and see the bush moving, I put poly bushes in and all good now , may be worth have the rear beam bushes checked for play


    Sent from my iPhone using Tapatalk

    Comment


    • #3
      So i've been out for a boot today, to try and see if there's any pattern as to when this occurs.. confirm that after a while it will make the squealing turning both left and right slightly..

      Applying the brakes gets rid of the noise.

      I've uploaded a video of the sound;

      https://www.youtube.com/watch?v=jVLA...ature=youtu.be
      Corsa VXR Nurburgring
      White

      Comment


      • #4
        Wheel bearing might be quite dry.
        sigpic
        OPC ةIRE- Drop me a PM for Irish meets, group adds etc.

        Comment


        • #5
          Originally posted by EL_Azz0 View Post
          So i've been out for a boot today, to try and see if there's any pattern as to when this occurs.. confirm that after a while it will make the squealing turning both left and right slightly..

          Applying the brakes gets rid of the noise.

          I've uploaded a video of the sound;

          https://www.youtube.com/watch?v=jVLA...ature=youtu.be
          That’s what mine sounded like it was the rear beam bushes


          Sent from my iPhone using Tapatalk

          Comment


          • #6
            Originally posted by GPH69 View Post
            That’s what mine sounded like it was the rear beam bushes
            Weird yeah? I'll have to get those switched out next then.

            Thanks for your replies guys, really appreciate it
            Corsa VXR Nurburgring
            White

            Comment

            Working...
            X