Announcement

Collapse
No announcement yet.

Corsa D VXR won’t rev past 4k

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ArdenAshVxr
    replied
    Hi guys thanks for all the input, I think I’m going to go ahead and get a compression kit/ test first before anything. Regarding what you guys said the MAF sensor, I did replace the Bosch one with a cheap one and that made it worst but I did replace it back to the Bosch one after the issues it was causing. The idling also doesn’t really make a diffence if anything it’s a little bit worse when unplugged however the stickyness when coming onto boost seems to go away. interms of boost leaks is there any obvious places or difficult places I should be checking and what’s the best way to check it myself?

    Leave a comment:


  • GPH69
    replied
    Originally posted by Arron D View Post
    His car is stock mate, a garage wouldnt suggest to map if there's a problem with the car. There's obviously some underlying issue with his which isn't normal.

    I would do a compression test to rule that out with p4 then take it from there. Kit is cheapish from Amazon or Halfords

    Sent from my D6503 using Tapatalk
    My local garage charged me £15 for compression test which isn’t too bad
    What condition are the plugs , are they oiled up? Brown/white?


    Sent from my iPhone using Tapatalk

    Leave a comment:


  • Arron D
    replied
    Originally posted by GPH69 View Post
    Mine started misfiring and would vibrate and shake when ticking over and I was told it was P4, I had compression test done and all cylinders were well over 180 so I took it and got it mapped and all worked great ever since


    Sent from my iPhone using Tapatalk
    His car is stock mate, a garage wouldnt suggest to map if there's a problem with the car. There's obviously some underlying issue with his which isn't normal.

    I would do a compression test to rule that out with p4 then take it from there. Kit is cheapish from Amazon or Halfords

    Also I know the garage you purchased it from is far away but I'd still contact them and see if they can help, did you have a warranty? if it's p4 it's a costly repair. And having it go on the way home from buying would be terrible

    Sent from my D6503 using Tapatalk
    Last edited by Arron D; 9th March 2019, 05:52 PM.

    Leave a comment:


  • GPH69
    replied
    Originally posted by u33db View Post
    You can unplug the MAF and see if it idles any better, that will tell you if your cheap one is causing an issue or not.

    Don't go to Vauxhall for a replacement as you'll get ripped off..proper Bosch ones can be got for about £90 form the likes of Nevlock Performance instead.

    You seem to have 2 issues....the idle problem which is hopefully the MAF and boost problem.

    The boost problem could also be the MAF but it could also be plugs, boost leak, duff recirfc valve and so on which you'll need to work though.

    I wouldn't expect P4 if the issues started after you buggered about with the MAF but a compression test would rule that out.

    Good luck
    Mine started misfiring and would vibrate and shake when ticking over and I was told it was P4, I had compression test done and all cylinders were well over 180 so I took it and got it mapped and all worked great ever since


    Sent from my iPhone using Tapatalk

    Leave a comment:


  • u33db
    replied
    You can unplug the MAF and see if it idles any better, that will tell you if your cheap one is causing an issue or not.

    Don't go to Vauxhall for a replacement as you'll get ripped off..proper Bosch ones can be got for about £90 form the likes of Nevlock Performance instead.

    You seem to have 2 issues....the idle problem which is hopefully the MAF and boost problem.

    The boost problem could also be the MAF but it could also be plugs, boost leak, duff recirfc valve and so on which you'll need to work though.

    I wouldn't expect P4 if the issues started after you buggered about with the MAF but a compression test would rule that out.

    Good luck

    Leave a comment:


  • ArdenAshVxr
    started a topic Corsa D VXR won’t rev past 4k

    Corsa D VXR won’t rev past 4k

    So I’ve been having an issue for a while now in my corsa d vxr (2010). The issue actually occurred the day I bought it back in Oct 2018. So first off I buy the car drive it back to Leicester which was roughly 50 miles then I gave it the beans and next think I know is I’ve got a light on the dash with a picture of a car with a spanner going through it.

    With this light coming on it didn’t allow the car to rev past 4K in neutral and the car feels very sticky when coming on boost (still occurs to this day).

    Since then I’ve taken it to a garage and they’ve cleared the code and replaced a solinoid and the problem still hasn’t gone.

    I’ve also tried cleaning the MAF sensor with the special spray from euro car parts and that hasn’t worked as well as replacing the MAF sensor for a cheap one but that just made the car pop and bang and completely ****** it 10x worse.

    On a cold start it will idle at 1.1/1.2k ish then as it drops to about 750/800 the car starts vibrating and the idling is quite rough but the revs aren’t moving about or anything.

    Has anyone got any suggestions to what this might be? I’m thinking myself it could just be the MAF sensor but I’ll probably just have to buy an expensive one but if anything reckons it could be something else or potentially piston 4 going can you please give me your imput because I really don’t know what to do about the current situation.

    P.S my car is stock and is currently on 44k miles
Working...
X