Announcement

Collapse
No announcement yet.

Fan is constantly on...

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fan is constantly on...

    As above, soon as i turn the engine on it starts and doesn't go off, engine is not even hot!

    Any ideas?

  • #2
    check the relay for the fan, or the temperature sensor.

    Somethings staying on constantly, could be the sensor causing the relay to stay energised.
    Whats next?!?!?

    Comment


    • #3
      Sorry mate but relay or temperature sensor means nothing to me!

      Comment


      • #4
        sorry mate, take it back to vauxhall they will sort it.

        I dont wana offend you, but ill explain in simple terms

        the temperature sensor monitors your coolant temp, and if it gets too high it switches the fan on to force air through your radiator to try and cool it.

        The fan is switched in through a control box (relay), it requires an input to switch on, and the temperature sensor is the input. So when it reaches 95c for example, the sensor sends a signal to the relay saying im too hot, and so switches your fan on.

        Hope that helps a bit
        Whats next?!?!?

        Comment


        • #5
          Thanks mate, don't worry, your not offending, I just not that mechanically minded!

          It's going back tomorrow, just wanted to see if people have experienced it, got an 100mile trip in the morning, will it be alright?

          Comment


          • #6
            yea itll be fine, all its gonna do is keep your coolant temp down

            will be a slight drain on the battery, but no problems. But seems as you got a long journey it wont bother the battery.
            Whats next?!?!?

            Comment


            • #7
              Thanks for your help mate!

              Comment


              • #8
                no worries, thats what were here for
                Whats next?!?!?

                Comment


                • #9
                  the car is going back to VX tomorrow, hopefully get sorted, having a few running problems which I assume is due to the engine being kept cool all the time!

                  Seem to have a problem with the heating too, it's not getting hot, would this be due to the temp sensor too!

                  Comment


                  • #10
                    Hi, just read the thread. Wouldn't it show up on the error list ?

                    Comment


                    • #11
                      Well The Heating Might Not Be Getting Hot As The Coolant Is Constantly Being Cooled By The Fan ?

                      Hope It All Gets Sorted Without And Probs
                      sigpic
                      - Corsa VXR - Arden Blue - Sight & Light Pack - Front Grill VXR Badge - ITG Panel Filter - Milltek Down Pipe - Milltek Catback System - TMS Bluefin Remap - Blue Samco Boost Hoses - Baileys DV26 BOV - 6000K HID Kit - Team Heko Wind Deflectors - 18" Black Vauxhall Alloys - Nurburgring Splitter - OPC Fog Surrounds - Tinted Fog Lights - CS Brake Ducts - Ultra Black Headlights - Tinted Windows - Hel Braided Brake Lines - Green Cotton Filter -

                      Comment


                      • #12
                        wouldn't like to guess but sure vauxhall will sort it out.

                        Rabbid Tuned - WG Motorworks
                        www.wgmotorworks.co.uk

                        Comment


                        • #13
                          i had the tech 2 on it, and it came up with temp sensor, it's going in tomorrow, i'll let you know how I get on......was freezing on the way to work!

                          Comment


                          • #14
                            ours is doing the exact same thing, so will take it in after xmas to see what they say

                            Comment

                            Working...
                            X