Announcement

Collapse
No announcement yet.

power loss

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • power loss

    was out a drive last nyt for a bit and the car just didnt seem right. It didnt seem to have the same power as usual can anything cause this?

    Cheers!

  • #2
    get a compression test mate.
    sigpic

    Comment


    • #3
      Lower octane fuel maybe? Ie old stock from the pumps...

      Alternatively have you just pumped in some 95 Ron unleaded? As there is a noticeable difference between 95 & 99 Ron.

      If yes to the 95, stick a can of octane booster in, that should clarify the above.

      Hope that is of some help.

      Need more info really, as your post is lacking detail.

      I notice the difference in feel as the fuel tank empties (ptwr)...

      Comment


      • #4
        using the same fuel mate. a dunno really how to explain it as it just didnt seem as quick when i put my foot down

        Comment


        • #5
          could be a problem with the diverter boost valve

          Comment


          • #6
            Could be anything to be fair.

            Rabbid Tuned - WG Motorworks
            www.wgmotorworks.co.uk

            Comment


            • #7
              Not a lot of info to go on.


              North East England - Tech 2 diagnostics/ code clearing available, Cruise control switches supplied fitted and activated . PM me for details

              Comment


              • #8
                Originally posted by Greg_VXR View Post
                was out a drive last nyt for a bit and the car just didnt seem right. It didnt seem to have the same power as usual can anything cause this?

                Cheers!
                probably getting used to the performance of your car ! happens all the time

                Comment

                Working...
                X